Simulasi Jaringan VoIP dan Data dengan Cisco Packet Tracer

VoIP (voice over Internet Protocol) adalah transmisi suara dan konten multimedia melalui koneksi internet. VoIP memungkinkan pengguna melakukan panggilan suara dari komputer,  telepon VoIP khusus, smartphone atau perangkat seluler lainnya.

Ilustrasi

Anda selaku administrator jaringan ditugaskan untuk membangun jaringan VoiP dan Jaringan Komputer Data dengan VLAN. Yang harus anda lakukan adalah

1. Menentukan IP Addres yaitu

  • Network untuk jaringan Data adalah 10.10.10.0/24
  • Network untuk jaringan Voice adalah 20.20.20.0/24

2. Konfigurasi IP Phone

  • Phone dial number 1 adalah 1011
  • Phone dial number 2 adalah 1012
  • Phone dial number 3 adalah 1013
  • Phone dial number 4 adalah 1014

Langkah Kerja

buatlah topologi jaringan sebagai berikut

Perangkat yang digunakan:

  1. Router 2811 (1 unit)
  2. Switch 2950-24 (1 unit)
  3. IP Phone (4 unit)
  4. PC (4 unit)

Konfigurasi Switch dengan CLI

kita akan menentukan VLAN untuk IP Phone dan PC Client

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name data
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name voice
Switch(config-vlan)#exit
Switch(config)#interface range fastethernet 0/2-5
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config-if-range)#switchport voice vlan 20
Switch(config-if-range)#exit
Switch(config)#interface fastethernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#end
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#

Mengaktifkan Port pada Router yang terhubung dengan Switch

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname VoIP
VoIP(config)#interface fastethernet 0/0
VoIP(config-if)#no shutdown

VoIP(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

VoIP(config-if)#exit
VoIP(config)#

Membuat sub Interface dengan perintah Encapsulation dot1Q

VoIP(config)#interface fastethernet 0/0.10
VoIP(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

VoIP(config-subif)#encapsulation dot1Q 10
VoIP(config-subif)#ip address 10.10.10.1 255.255.255.0
VoIP(config-subif)#description untuk-jaringan-data
VoIP(config-subif)#exit
VoIP(config)#interface fastethernet 0/0.20
VoIP(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

VoIP(config-subif)#encapsulation dot1Q 20
VoIP(config-subif)#ip address 20.20.20.1 255.255.255.0
VoIP(config-subif)#description untuk-jaringan-VoIP
VoIP(config-subif)#exit
VoIP(config)#

Setting DHCP Pool pada Router

VoIP(config)#ip dhcp excluded-address 10.10.10.1
VoIP(config)#ip dhcp excluded-address 20.20.20.1
VoIP(config)#ip dhcp pool data
VoIP(dhcp-config)#network 10.10.10.0 255.255.255.0
VoIP(dhcp-config)#default-router 10.10.10.1
VoIP(dhcp-config)#dns-server 8.8.8.8
VoIP(dhcp-config)#exit
VoIP(config)#ip dhcp pool voice
VoIP(dhcp-config)#network 20.20.20.0 255.255.255.0
VoIP(dhcp-config)#default-router 20.20.20.1
VoIP(dhcp-config)#option 150 ip 20.20.20.1
VoIP(dhcp-config)#exit
VoIP(config)#

Telephony Services mensetting Dial Number untuk IP Phone

VoIP(config)#telephony-service
VoIP(config-telephony)#max-ephones 4
VoIP(config-telephony)#max-dn 4
VoIP(config-telephony)#ip source-address 20.20.20.1 port 2000
VoIP(config-telephony)#auto assign 1 to 4
VoIP(config-telephony)#exit
VoIP(config)#ephone-dn 1
VoIP(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 1.1, changed state to up

VoIP(config-ephone-dn)#number 1011
VoIP(config-ephone-dn)#
%IPPHONE-6-REGISTER: ephone-1 IP:192.168.20.2 Socket:2 DeviceType:Phone has registered.

VoIP(config-ephone-dn)#ephone-dn 2
VoIP(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 2.1, changed state to up

VoIP(config-ephone-dn)#number 1012
VoIP(config-ephone-dn)#
%IPPHONE-6-REGISTER: ephone-3 IP:192.168.20.3 Socket:2 DeviceType:Phone has registered.

VoIP(config-ephone-dn)#ephone-dn 3
VoIP(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 3.1, changed state to up

VoIP(config-ephone-dn)#number 1013
VoIP(config-ephone-dn)#
%IPPHONE-6-REGISTER: ephone-2 IP:192.168.20.4 Socket:2 DeviceType:Phone has registered.

VoIP(config-ephone-dn)#ephone-dn 4
VoIP(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 4.1, changed state to up

VoIP(config-ephone-dn)#number 1014
VoIP(config-ephone-dn)#
%IPPHONE-6-REGISTER: ephone-4 IP:192.168.20.5 Socket:2 DeviceType:Phone has registered.

VoIP(config-ephone-dn)#end
%SYS-5-CONFIG_I: Configured from console by console

VoIP#

Langkah Terakhir Pengujian Perangakat IP Phone dan PC Client

Sebelum melakukan pengujian pastikan IP Phone sudah dalam keadaan aktif, dan merubah IP Address pada PC yang sebelumnya STATIC menjadi DHCP

Dial IP Phone = Conected

IP Phone berhasil terhubung

Hasil Pengujian PC Client Successful

Terimakasih, dan selamat BELAJAR

Leave a Reply

Your email address will not be published. Required fields are marked *